Dukascopy News
01 July 2015
Important changes on Dukascopy server accessibility!
Please be aware that starting from Monday, 6th of July, 2015 Dukascopy will support only Java/JForex version 2.42+ on LIVE and clients attempting to use the older versions will not be able to access LIVE trading.
IMPORTANT! Clients using JForex SDK, please make sure you download the latest JForex SDK version, you can find it here.