Dukascopy
 
 
Wiki JStore Search Login

Start of older JForex
 Post subject: Start of older JForex Post rating: 0   New post Posted: Wed 26 Jun, 2013, 17:39 
User avatar

User rating: 21
Joined: Thu 19 May, 2011, 20:50
Posts: 384
Location: Germany, Munich
Hi Support,

is there any possibility to start an older version of JForex DEMO?
The current version has bugs in the Historical Tester, so my current work is stopped (again).
These bugs cost me hours and hours. It is very frustrating.

Kind regards

Bernhard Schicht
Stash GmbH


 
 Post subject: Re: Start of older JForex Post rating: 0   New post Posted: Thu 27 Jun, 2013, 11:43 
User avatar

User rating: 164
Joined: Mon 08 Oct, 2012, 10:35
Posts: 676
Location: NetherlandsNetherlands
The jnlp file, that triggers javaws to load the platform, contains the version of the java packages (.jar).
You could give it a try to modify these version string, and use a earlier JForex version for example, but I hardly believe you will succeed.

Keep in mind that there are possibly cross references and dependencies between the different packages. So who knows what package version (from jcalendar, commons-lang, JForex-API, just to name a few) should be used for a previous JForex platform?

Edit:
You can maybe consider using the JForex-SDK and its TesterMainGUI class. I don`t know what features do you rely on from the platforms Historical Tester (like Visible chart, or just continuous execution with different parameter sets), but maybe the functions that are not working for you at the moment can be used/implemented in the standalone tester.


 
 Post subject: Re: Start of older JForex Post rating: 0   New post Posted: Thu 27 Jun, 2013, 13:28 
JForex Master
User avatar

User rating:
Joined: Wed 16 Sep, 2009, 18:23
Posts: 1007
Location: Geneva, Switzerland
No it is not possible. Please elaborate on the issues with Historical Tester.


 
 Post subject: Re: Start of older JForex Post rating: 0   New post Posted: Mon 21 Jan, 2019, 11:10 
User avatar

User rating: 21
Joined: Thu 19 May, 2011, 20:50
Posts: 384
Location: Germany, Munich
I am having an issue with the latest JForex demo 3.4.14. This version does not launch on my Linux Ubuntu MATE desktop. Version 3.4.13 still works fine (this is the current live JForex version)
There has to be a possibility to fallback to older versions in such cases, otherwise this is a full show stopper.

Please add this feature.


 
 Post subject: Re: Start of older JForex Post rating: 0   New post Posted: Thu 24 Jan, 2019, 18:21 
User avatar

User rating: 21
Joined: Thu 19 May, 2011, 20:50
Posts: 384
Location: Germany, Munich
I cannot work like this if JForex does not launch. Isn't there a secret link, so I could start an older JForex version?
Please help!


 
 Post subject: Re: Start of older JForex Post rating: 0   New post Posted: Wed 30 Jan, 2019, 12:47 
JForex Master
User avatar

User rating:
Joined: Wed 16 Sep, 2009, 18:23
Posts: 1007
Location: Geneva, Switzerland
New version has been deployed to solve this problem.

We will make it possible to launch the previous version on the installed JForex as well. That previous version will be kept on the local disk.


 

Jump to:  

cron
  © 1998-2011 Dukascopy® Bank SA
On-line Currency forex trading with Swiss Forex Broker - ECN Forex Brokerage,
Managed Forex Accounts, introducing forex brokers, Currency Forex Data Feed and News
Currency Forex Trading Platform provided on-line by Dukascopy.com