Dukascopy Support Board
http://www.dukascopy.com/swiss/english/forex/jforex/forum/

Upgrading JForex API 3.6.14 to 3.6.19
http://www.dukascopy.com/swiss/english/forex/jforex/forum/viewtopic.php?f=16&t=57375
Page 1 of 1

Author:  reason [ Tue 23 Jun, 2020, 10:04 ]
Post subject:  Upgrading JForex API 3.6.14 to 3.6.19

Dear all,

When upgrading our Java application from using JForex API 3.6.14 to 3.6.19, the following error appears:

* What went wrong:
Execution failed for task ':compileGroovy'.
> Could not resolve all files for configuration ':compileClasspath'.
   > Could not find com.dukascopy:dev-tools:1.0.29.
     Searched in the following locations:
       - https://repo.maven.apache.org/maven2/com/dukascopy/dev-tools/1.0.29/dev-tools-1.0.29.pom
       - https://repo.maven.apache.org/maven2/com/dukascopy/dev-tools/1.0.29/dev-tools-1.0.29.jar
       - http://www.dukascopy.com/client/jforexlib/publicrepo/com/dukascopy/dev-tools/1.0.29/dev-tools-1.0.29.pom
       - http://www.dukascopy.com/client/jforexlib/publicrepo/com/dukascopy/dev-tools/1.0.29/dev-tools-1.0.29.jar
     Required by:
         project : > com.dukascopy.dds2:DDS2-jClient-JForex:3.6.19 > com.dukascopy.dds2:DDS2-Charts:6.24.100 > com.dukascopy.dds2:greed-common:318.4.101
   > Could not find com.dukascopy:dev-tools:1.0.29.
     Searched in the following locations:
       - https://repo.maven.apache.org/maven2/com/dukascopy/dev-tools/1.0.29/dev-tools-1.0.29.pom
       - https://repo.maven.apache.org/maven2/com/dukascopy/dev-tools/1.0.29/dev-tools-1.0.29.jar
       - http://www.dukascopy.com/client/jforexlib/publicrepo/com/dukascopy/dev-tools/1.0.29/dev-tools-1.0.29.pom
       - http://www.dukascopy.com/client/jforexlib/publicrepo/com/dukascopy/dev-tools/1.0.29/dev-tools-1.0.29.jar
     Required by:
         project : > com.dukascopy.dds2:DDS2-jClient-JForex:3.6.19 > com.dukascopy.dds2:DDS2-Charts:6.24.100 > com.dukascopy.dds2:greed-common:318.4.101 > com.dukascopy.dds2:msg:1.1.88 > com.dukascopy:system-msg:1.0.33 > com.dukascopy:transport-core:1.1.26


We want to use the new "Weekend filter" feature using the API and are hoping an upgrade to API 3.6.19 will fix this.

  Page 1 of 1