Dukascopy
 
 
Wiki JStore Search Login


Build API: 2.13.42 Client: 3.2.17 / Date 2017-Oct-04
 Post subject: Build API: 2.13.42 Client: 3.2.17 / Date 2017-Oct-04 Post rating: 0   New post Posted: Thu 05 Oct, 2017, 09:10 
User avatar

User rating:
Joined: Fri 31 Aug, 2007, 09:17
Posts: 6073
ARTIFACTS VERSIONS:
DDS2-jClient-JForex 3.2.17
JForex-API 2.13.42

New:
JFOREX-9163 Calculation and drawing of indicators with larger custom period.
JFOREX-9217 Improve OHLC widget menu.
JFOREX-9146 Display drawing object's coordinates distance.
JFOREX-8996 New instruments: EURTHB, EURCZK, USDTHB, USDILS
APICLIENT-2345 Provide API method to detect if an instrument is tradable
APICLIENT-2407 JFUtils.getRate(ICurrency from, ICurrency to) - get exchange rate between any two currencies

Latest SDK download:
http://www.dukascopy.com/client/jforexl ... -3-SDK.zip
API Javadocs:
https://www.dukascopy.com/client/javadoc3/


 
 Post subject: Re: Build API: 2.13.42 Client: 3.2.17 / Date 2017-Oct-04 Post rating: 0   New post Posted: Thu 05 Oct, 2017, 11:05 
User avatar

User rating: 8
Joined: Mon 09 Jun, 2014, 21:07
Posts: 49
Location: Poland, Warsaw
Hi,

Cannot build my projects using maven and the newest API. This is the error I am getting:

[WARNING] The POM for 7zip:7zip:jar:16.04 is missing, no dependency information available


[ERROR] Failed to execute goal on project xxx: Could not resolve dependencies for project eu.smartfx.xxx:xxx:jar:3: Could not find artifact 7zip:7zip:jar:16.04 in dc_public (http://www.dukascopy.com/client/jforexlib/publicrepo/) -> [Help 1]


Best regards,
Greg


 
 Post subject: Re: Build API: 2.13.42 Client: 3.2.17 / Date 2017-Oct-04 Post rating: 2   New post Posted: Fri 06 Oct, 2017, 23:47 
User avatar

User rating: 8
Joined: Mon 09 Jun, 2014, 21:07
Posts: 49
Location: Poland, Warsaw
Is it only me? I removed my local Maven repository, cleaned workspace but nothing helps. Still cannot build my code with the newest API.

Please support.

Best regards,
Greg


 
 Post subject: Re: Build API: 2.13.42 Client: 3.2.17 / Date 2017-Oct-04 Post rating: 1   New post Posted: Sat 07 Oct, 2017, 09:32 

User rating: 3
Joined: Mon 23 May, 2011, 16:06
Posts: 17
Location: Hungary,
Dear Support Team,

I can confirm what Greg wrote on the dependency issue of the API you've just released (DDS2-jClient-JForex:3.2.17). I can't use it either for building IDE projects.

I believe the problem is that the pom file of the new DDS2-jClient-JForex excludes the 7zip:7zip:4.65 dependency, which was included in the previous version (3.2.13). The pom of the new greed-common includes a dependency 7zip:7zip:16.04 - but it is another version, anyway. And, JForex Maven repository contains only the 4.65 version of 7-zip, so there's no place to download the version 16.04 from. That explains the error message that we, the early birds have received.

Regards,
Argiris


 
 Post subject: Re: Build API: 2.13.42 Client: 3.2.17 / Date 2017-Oct-04 Post rating: 0   New post Posted: Mon 09 Oct, 2017, 20:55 

User rating: 0
Joined: Fri 22 May, 2015, 10:10
Posts: 10
Location: France,
Dear Team Support,

the last timestamp of the release of JForex-3-SDK.zip is :
2017-Oct-09 10:21:54

and there's the same trouble.
7zip-16.04.jar is missing.

it's a blocking point for me.

Regards,

Jeannot


 
 Post subject: Re: Build API: 2.13.42 Client: 3.2.17 / Date 2017-Oct-04 Post rating: 0   New post Posted: Mon 09 Oct, 2017, 21:35 
User avatar

User rating: 0
Joined: Tue 05 Jul, 2011, 15:21
Posts: 28
Location: Switzerland,
I have the same problem. Analyzing Dukascopy Public Repository one can find only this path:
https://www.dukascopy.com/client/jforex ... 7zip/7zip/

But the 7zip version 16.04 is missing.

On http://www.7-zip.org/sdk.html there is a year-old download link to this version: http://www.7-zip.org/a/lzma1604.7z

Could Support please post the required 7zip version to Dukascopy Public Repository ?

Thanks !


 
 Post subject: Re: Build API: 2.13.42 Client: 3.2.17 / Date 2017-Oct-04 Post rating: 0   New post Posted: Tue 10 Oct, 2017, 11:54 

User rating: 0
Joined: Fri 22 May, 2015, 10:10
Posts: 10
Location: France,
Hello,

the 7zip-16.04.jar is available since 2017-Oct-10 08:08:46 at the right place.
The maven dependencies are complete and my project is building.

Really thanks to the support team.

Best Regards,

Jeannot


 

Jump to:  

cron
  © 1998-2011 Dukascopy® Bank SA
On-line Currency forex trading with Swiss Forex Broker - ECN Forex Brokerage,
Managed Forex Accounts, introducing forex brokers, Currency Forex Data Feed and News
Currency Forex Trading Platform provided on-line by Dukascopy.com